2002-2006 Mini Cooper (R50)

Just another A/C post!!!

  #1  
Old 08-30-2015, 08:51 AM
Junior Member
Thread Starter
Join Date: Aug 2015
Posts: 2
Default Just another A/C post!!!

2003 Mini Cooper!!

Current Symptoms.
1. Light on A/c Switch on solid (no blinking)
2. Yes, I can hear the compressor turning on/off
3. Low speed fan does not turn on when A/c is turned on.
4. When I attempt to recharge the R123a i get half way and the high pressure dump valve on the compressor opens.

A/c stopped working by dumping the refrigerant out the port on the bottom. During troubleshooting I found out the my low speed resistor was shot. Replaced!! I tested afterwards by jumpering the battery to the connector pins and fan worked in both speeds. I recharged with more r123A but didn't get halfway through the can and it dumped again. I noticed that the fan wasn't operating.

Since I replaced the fan resistor I expected the fan to turn on when the A/c is ON, correct??

I don't want to waste another can of r123a.....should I recharge or will it dump again?

Should the fan be ON with the A/C on?
What else should I do?


Thanks
Doug
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
scottkrough
New Member Area
11
02-06-2014 02:12 PM
oldfrt48
New Member Area
1
05-28-2011 10:30 PM
DGRAY02
Tires, Wheels, and Brakes
0
01-08-2008 08:24 PM
m3dragon
Off Topic
5
10-01-2007 01:03 PM
Perry Mason
New Member Area
0
06-29-2006 01:49 AM


Thread Tools
Search this Thread
Quick Reply: Just another A/C post!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.