2002-2006 Mini Cooper (R50)

Lots of issues..

  #1  
Old 02-09-2013, 07:27 PM
Junior Member
Thread Starter
Join Date: Feb 2013
Location: SC
Posts: 3
Default Lots of issues..

Alright, I normally hang out in a mustang forum but my bf has a mini coop and it's having some issues.. They're trying to help but though maybe yous guys had more input? Here we go..

03 mini cooper..

Few weeks ago started having some random issues of dash lights going out and ****.. that was usually solved with a swift hit to the dash. they'd come back on. Then one day the gauges stopped working and when you turned the car off, the air would stay on. Not like just the car cooling down or anything.. I mean you turned on the heater or ac and it would blow, which, wasn't that big of a deal because you could just turn it to 'off' and it turned off. Well, I guess he left the heat on or something when he got out of the car and the car was dead when he tried to go to work this am. Got home, tried to jump it and the cables got super effin' hot and it killed my car's battery too... though.. my car started up just fine after I disconnected the cables. I hooked a battery charger to it and let it full charge, car didn't start.. but the lights were trying to come on.. let it charge for an extra couple of hours and tried again.. absolutely dead. No lights, no attempt to turn over, no radio.. nothing.

(That was yesterday..)


(today) Checked all of the fuses when we got home, just in case.. All were good except the one for the gauges which is now replaced. When he opened the car it sounded like it was stuck in the 'try to start' mode. There was a continuous clicking sound, I pulled the plug out of the immobiliser (had to take a picture of it and look it up to even know wth it was, lol) but then it turned into sounding like the turn signal was stuck on.. So i started pulling fuses.. and got it to stop by pulling one of the large fuses. The picture to the one that made the sound stop was a fan?




SO.. one of the lights on the gauges comes on but its very faint. I guess we're going to take the battery to AAP tomorrow and get it tested.. >.>


Past that.. any suggestions? I'm really hoping its not needing the ECU replaced.. I just see that as a huge headache and lots of $$..
 
  #2  
Old 02-09-2013, 08:30 PM
Super Moderator
Join Date: Feb 2008
Posts: 2,309
Default

It sounds like you have a fan relay stuck on ...
You might also have a bad starter solenoid
I'd test the battery first
 
  #3  
Old 02-10-2013, 07:07 PM
Junior Member
Thread Starter
Join Date: Feb 2013
Location: SC
Posts: 3
Default

battery was bad. replaced it. all of the lights come on now, but still no start.

would it mess things up if i had unplugged and plugged back in the imobiliser?
 
  #4  
Old 02-11-2013, 09:18 AM
Super Moderator
Join Date: Feb 2008
Posts: 2,309
Default

When you say no start does it crank ? just not fire or no crank
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jamiebean80
2002-2006 Mini Cooper (R50)
6
07-07-2011 01:20 PM
omnivector
PRIVATE For Sale / Trade Classifieds
3
11-14-2009 12:54 PM
mj217
PRIVATE For Sale / Trade Classifieds
0
09-01-2009 09:41 AM
Squirrrelx
PRIVATE For Sale / Trade Classifieds
4
04-14-2008 05:54 PM
trovan
New Member Area
2
05-17-2007 11:13 PM


Thread Tools
Search this Thread
Quick Reply: Lots of issues..


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.