2002-2006 Mini Cooper S (R53)
Sponsored by:
Sponsored by:

2003 Cooper s- fuel filter replaced, now no start

  #1  
Old 06-03-2018, 04:36 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 1
Default 2003 Cooper s- fuel filter replaced, now no start

I recently replaced my fuel pump.everything worked fine and I decided to change the fuel filter yesterday. I changed the filter and put everything back together and now the car won't start. I filled the gas tank and double checked all the o-rings but still no start. The car turns over but no start. My first thought was fuel pressure but I'm lost at this point
 
  #2  
Old 08-06-2018, 01:52 AM
Junior Member
Join Date: Aug 2018
Posts: 2
Default

Did you disconnect the battery? If you did it could possibly just be the computer having to relearn itself and trying to find a base idle.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tmihalic
08-up MINI Clubman/Traveller (R55)
1
03-20-2018 08:59 AM
tmihalic
General Tech
1
11-22-2017 01:05 PM


Thread Tools
Search this Thread
Quick Reply: 2003 Cooper s- fuel filter replaced, now no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.