2002-2006 Mini Cooper S (R53)
Sponsored by:
Sponsored by:

New to forum, a few questions and a Hello!

  #1  
Old 01-30-2017, 07:58 PM
Junior Member
Thread Starter
Join Date: Jan 2017
Posts: 2
Default New to forum, a few questions and a Hello!

Hello all, My names Jordan, new to the forums. I have a 2005 Mini Cooper S that i acquired back in August 2016, I bought it from a dealer who told me it was a repossessed Mini. the unknown previous owner did some work to the mini, BC coilovers, Alta supercharger pulley, and some less than trustworthy Gauges ( Boost, Volt, Oil pressure, A/F ratio).. I love my mini even with its few...odd quirks. a few questions I have;

this happened about two weeks ago, I was driving home from work and was taking a fun road, downshifted to second, and hit about 6700 rpm, and my aftermarket stereo cut out, i pulled over into a parking lot and inspected my amplifier in the back and found its fuse was blown, having some spares i disconnected battery and put the new fuse in ( was correct amp. fuse) and as soon as I hooked the battery back up the fuse blew again, instantly. I dont feel this is a wiring error, but something in the Mini. It had done this before when it had the stock HarmanKardon set-up, although the factory stereo had just cut out for about 3 seconds on a high rpm pull and came back on like normal after i let out of it. Any suggestions on what this may be?

one other question I have that I have is it has a solid clunk when I drive from a stop, does it in reverse and 1st. it also seems like it only does it once in 1st and will only happen again when you shift into reverse, like it has to shift back the other way, then it will do it again when you drive off. I'd like to make a guess at maybe my control arm bushing? the one in the back. I have read that some people say it is the motor mount, but I would think with its characteristics it would be more suspension related. Anyways, just some questions maybe someone can give me advice on. Thank you!
 
  #2  
Old 01-30-2017, 08:04 PM
Junior Member
Thread Starter
Join Date: Jan 2017
Posts: 2
Default

Picture of my Mini! (No Front bumper from Repo truck I'm assuming)
 
Attached Thumbnails New to forum, a few questions and a Hello!-mini.jpg  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DaileyDriver
New Member Area
5
11-30-2017 07:09 AM
phantomesq
New Member Area
3
03-28-2013 07:33 AM
Jaked937
New Member Area
1
10-23-2012 11:49 AM
kirker912
General Mini Cooper Talk
2
03-27-2010 02:14 PM
Cooper_R53
2002-2006 Mini Cooper S (R53)
3
01-24-2009 01:34 AM


Thread Tools
Search this Thread
Quick Reply: New to forum, a few questions and a Hello!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.