Engine lag off idle

  #1  
Old 06-29-2017, 12:31 PM
Junior Member
Thread Starter
Join Date: Jun 2017
Posts: 1
Default Engine lag off idle

So, I've had my 2013 Clubman base for 2 years and have always had a problem with engine lag coming off idle, especially when the AC is on. Overall this isn't too big an issue, but if I'm trying to get into traffic when it's heavy, it can be dangerous. The dealer said it was normal, but to me it just doesn't seem right. There are times the engine wants to stall even (only when the AC is on on super hot days). It's an automatic transmission which adds to the problem.

I guess what I'm getting at is, has anyone else had this issue and what can be done to resolve it? Would the Remus Responder, or similar device, help?

Any help would be greatly appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rocketfan
2002-2006 Mini Cooper (R50)
1
10-20-2015 01:08 PM
ber
General Tech
0
04-21-2014 10:55 AM
Done Swimmin
General Tech
5
01-26-2012 05:18 AM
jrettew
General Tech
14
05-03-2011 12:31 PM
andshesaidtwice
General Tech
1
03-19-2010 11:42 AM


Thread Tools
Search this Thread
Quick Reply: Engine lag off idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.